ALPINE-CVE-2020-8927
ALPINE-CVE-2020-8927
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
CVSS 6.5 · Средний · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
brotli Alpine:v3.12
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.15
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.16
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.17
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.18
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.19
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.20
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.21
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.22
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.23
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0
brotli Alpine:v3.24
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.0.9-r0
Обновитесь до 1.0.9-r0