ALPINE-CVE-2023-23936
ALPINE-CVE-2023-23936
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the `headers.host` string before passing to undici.
CVSS 5.4 · Средний · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
nodejs Alpine:v3.15
- Затронутые диапазоны версий
- ECOSYSTEM: < 16.19.1-r0
Обновитесь до 16.19.1-r0
nodejs Alpine:v3.16
- Затронутые диапазоны версий
- ECOSYSTEM: < 16.19.1-r0
Обновитесь до 16.19.1-r0
nodejs Alpine:v3.17
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0
nodejs Alpine:v3.18
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0
nodejs Alpine:v3.19
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0
nodejs Alpine:v3.20
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0
nodejs Alpine:v3.21
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0
nodejs Alpine:v3.22
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0
nodejs Alpine:v3.23
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0
nodejs Alpine:v3.24
- Затронутые диапазоны версий
- ECOSYSTEM: < 18.14.1-r0
Обновитесь до 18.14.1-r0