p PatchFirst

ALPINE-CVE-2023-24807

ALPINE-CVE-2023-24807

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Undici is an HTTP/1.1 client for Node.js. Prior to version 5.19.1, the `Headers.set()` and `Headers.append()` methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the `headerValueNormalize()` utility function. This vulnerability was patched in v5.19.1. No known workarounds are available.

CVSS 7.5 · Высокий · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • nodejs Alpine:v3.15

    Затронутые диапазоны версий
    • ECOSYSTEM: < 16.19.1-r0

    Обновитесь до 16.19.1-r0

  • nodejs Alpine:v3.16

    Затронутые диапазоны версий
    • ECOSYSTEM: < 16.19.1-r0

    Обновитесь до 16.19.1-r0

  • nodejs Alpine:v3.17

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

  • nodejs Alpine:v3.18

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

  • nodejs Alpine:v3.19

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

  • nodejs Alpine:v3.20

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

  • nodejs Alpine:v3.21

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

  • nodejs Alpine:v3.22

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

  • nodejs Alpine:v3.23

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

  • nodejs Alpine:v3.24

    Затронутые диапазоны версий
    • ECOSYSTEM: < 18.14.1-r0

    Обновитесь до 18.14.1-r0

Первоисточники

Проверьте свой сервер →