ALPINE-CVE-2024-27280
ALPINE-CVE-2024-27280
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A buffer-overread issue was discovered in StringIO 3.0.1, as distributed in Ruby 3.0.x through 3.0.6 and 3.1.x through 3.1.4. The ungetbyte and ungetc methods on a StringIO can read past the end of a string, and a subsequent call to StringIO.gets may return the memory value. 3.0.3 is the main fixed version; however, for Ruby 3.0 users, a fixed version is stringio 3.0.1.1, and for Ruby 3.1 users, a fixed version is stringio 3.0.1.2.
CVSS 9.8 · Критический · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
ruby Alpine:v3.16
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.1.5-r0
Обновитесь до 3.1.5-r0
ruby Alpine:v3.17
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.1.5-r0
Обновитесь до 3.1.5-r0
ruby Alpine:v3.18
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.2.4-r0
Обновитесь до 3.2.4-r0
ruby Alpine:v3.19
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.2.4-r0
Обновитесь до 3.2.4-r0
ruby Alpine:v3.20
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.21
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.22
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.23
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.24
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0