ALPINE-CVE-2024-27282
ALPINE-CVE-2024-27282
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.
CVSS 6.6 · Средний · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
ruby Alpine:v3.16
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.1.5-r0
Обновитесь до 3.1.5-r0
ruby Alpine:v3.17
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.1.5-r0
Обновитесь до 3.1.5-r0
ruby Alpine:v3.18
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.2.4-r0
Обновитесь до 3.2.4-r0
ruby Alpine:v3.19
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.2.4-r0
Обновитесь до 3.2.4-r0
ruby Alpine:v3.20
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.21
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.22
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.23
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0
ruby Alpine:v3.24
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.1-r0
Обновитесь до 3.3.1-r0