ALPINE-CVE-2024-38474
ALPINE-CVE-2024-38474
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI. Users are recommended to upgrade to version 2.4.60, which fixes this issue. Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.
CVSS 9.8 · Критический · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache2 Alpine:v3.17
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0
apache2 Alpine:v3.18
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0
apache2 Alpine:v3.19
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0
apache2 Alpine:v3.20
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0
apache2 Alpine:v3.21
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0
apache2 Alpine:v3.22
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0
apache2 Alpine:v3.23
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0
apache2 Alpine:v3.24
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.4.60-r0
Обновитесь до 2.4.60-r0