p PatchFirst

ALPINE-CVE-2024-40725

ALPINE-CVE-2024-40725

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A partial fix for  CVE-2024-39884 in the core of Apache HTTP Server 2.4.61 ignores some use of the legacy content-type based configuration of handlers. "AddType" and similar configuration, under some circumstances where files are requested indirectly, result in source code disclosure of local content. For example, PHP scripts may be served instead of interpreted. Users are recommended to upgrade to version 2.4.62, which fixes this issue.

CVSS 5.3 · Средний · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache2 Alpine:v3.17

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

  • apache2 Alpine:v3.18

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

  • apache2 Alpine:v3.19

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

  • apache2 Alpine:v3.20

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

  • apache2 Alpine:v3.21

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

  • apache2 Alpine:v3.22

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

  • apache2 Alpine:v3.23

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

  • apache2 Alpine:v3.24

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.62-r0

    Обновитесь до 2.4.62-r0

Первоисточники

Проверьте свой сервер →