p PatchFirst

ALPINE-CVE-2025-31115

ALPINE-CVE-2025-31115

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

XZ Utils provide a general-purpose data-compression library plus command-line tools. In XZ Utils 5.3.3alpha to 5.8.0, the multithreaded .xz decoder in liblzma has a bug where invalid input can at least result in a crash. The effects include heap use after free and writing to an address based on the null pointer plus an offset. Applications and libraries that use the lzma_stream_decoder_mt function are affected. The bug has been fixed in XZ Utils 5.8.1, and the fix has been committed to the v5.4, v5.6, v5.8, and master branches in the xz Git repository. No new release packages will be made from the old stable branches, but a standalone patch is available that applies to all affected releases.

CVSS 8.7 · Высокий · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • xz Alpine:v3.18

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.3-r1

    Обновитесь до 5.4.3-r1

  • xz Alpine:v3.19

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.5-r1

    Обновитесь до 5.4.5-r1

  • xz Alpine:v3.20

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.6.2-r1

    Обновитесь до 5.6.2-r1

  • xz Alpine:v3.21

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.6.3-r1

    Обновитесь до 5.6.3-r1

  • xz Alpine:v3.22

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.8.1-r0

    Обновитесь до 5.8.1-r0

  • xz Alpine:v3.23

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.8.1-r0

    Обновитесь до 5.8.1-r0

  • xz Alpine:v3.24

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.8.1-r0

    Обновитесь до 5.8.1-r0

Первоисточники

Проверьте свой сервер →