p PatchFirst

ALPINE-CVE-2025-61594

ALPINE-CVE-2025-61594

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

CVSS 7.5 · Высокий · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • ruby Alpine:v3.20

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.3.10-r0

    Обновитесь до 3.3.10-r0

  • ruby Alpine:v3.21

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.3.10-r0

    Обновитесь до 3.3.10-r0

  • ruby Alpine:v3.22

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.4.7-r0

    Обновитесь до 3.4.7-r0

  • ruby Alpine:v3.23

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.4.7-r0

    Обновитесь до 3.4.7-r0

  • ruby Alpine:v3.24

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.4.7-r0

    Обновитесь до 3.4.7-r0

Первоисточники

Проверьте свой сервер →