p PatchFirst

CVE-2016-4975

CVE-2016-4975 · mod_userdir CRLF injection

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.

Possible CRLF injection allowing HTTP response splitting attacks for sites which use mod_userdir. This issue was mitigated by changes made in 2.4.25 and 2.2.32 which prohibit CR or LF injection into the "Location" or other outbound header key or value. Fixed in Apache HTTP Server 2.4.25 (Affected 2.4.1-2.4.23). Fixed in Apache HTTP Server 2.2.32 (Affected 2.2.0-2.2.31).

CVSS 6.1 · Средний · EPSS 19,8% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: system · web

Затронутые продукты и версии

  • apache httpd

    Версии
    • Fixed in Apache HTTP Server 2.4.25 (Affected 2.4.1-2.4.23): Затронуто
    • Fixed in Apache HTTP Server 2.2.32 (Affected 2.2.0-2.2.31): Затронуто

    Нет опубликованного исправления

  • apache2 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.25-1

    Обновитесь до 2.4.25-1

  • apache2 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.25-1

    Обновитесь до 2.4.25-1

  • apache2 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.25-1

    Обновитесь до 2.4.25-1

  • apache2 Ubuntu:14.04:LTS

    Версии
    • 2.4.6-2ubuntu2
    • 2.4.6-2ubuntu3
    • 2.4.6-2ubuntu4
    • 2.4.7-1ubuntu1
    • 2.4.7-1ubuntu2
    • 2.4.7-1ubuntu3
    • 2.4.7-1ubuntu4
    • 2.4.7-1ubuntu4.1
    • 2.4.7-1ubuntu4.4
    • 2.4.7-1ubuntu4.5
    • 2.4.7-1ubuntu4.6
    • 2.4.7-1ubuntu4.7
    • 2.4.7-1ubuntu4.8
    • 2.4.7-1ubuntu4.9
    • 2.4.7-1ubuntu4.10
    • 2.4.7-1ubuntu4.11
    • 2.4.7-1ubuntu4.13
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.7-1ubuntu4.15

    Обновитесь до 2.4.7-1ubuntu4.15

  • apache2 Ubuntu:16.04:LTS

    Версии
    • 2.4.12-2ubuntu2
    • 2.4.17-1ubuntu1
    • 2.4.17-2ubuntu1
    • 2.4.17-3ubuntu1
    • 2.4.18-1ubuntu1
    • 2.4.18-2ubuntu1
    • 2.4.18-2ubuntu2
    • 2.4.18-2ubuntu3
    • 2.4.18-2ubuntu3.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.18-2ubuntu3.2

    Обновитесь до 2.4.18-2ubuntu3.2

Первоисточники

Проверьте свой сервер →