CVE-2016-6816
CVE-2016-6816
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.
The code in Apache Tomcat 9.0.0.M1 to 9.0.0.M11, 8.5.0 to 8.5.6, 8.0.0.RC1 to 8.0.38, 7.0.0 to 7.0.72, and 6.0.0 to 6.0.47 that parsed the HTTP request line permitted invalid characters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack and/or obtain sensitive information from requests other then their own.
CVSS 7.1 · Высокий · EPSS 39,6% · Публичный эксплойт · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache tomcat
- Версии
- 9.0.0.M1 to 9.0.0.M11: Затронуто
- 8.5.0 to 8.5.6: Затронуто
- 8.0.0.RC1 to 8.0.38: Затронуто
- 7.0.0 to 7.0.72: Затронуто
- 6.0.0 to 6.0.47: Затронуто
- Earlier, unsupported versions may also be affected.: Затронуто
Нет опубликованного исправления
tomcat7 Ubuntu:14.04:LTS
- Версии
- 7.0.42-1
- 7.0.47-1
- 7.0.50-1
- 7.0.52-1
- 7.0.52-1ubuntu0.1
- 7.0.52-1ubuntu0.3
- 7.0.52-1ubuntu0.6
- 7.0.52-1ubuntu0.7
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.0.52-1ubuntu0.8
Обновитесь до 7.0.52-1ubuntu0.8
tomcat6 Ubuntu:Pro:14.04:LTS
- Версии
- 6.0.37-1
- 6.0.39-1
- 6.0.39-1ubuntu0.1
- 6.0.39-1ubuntu0.1+esm1
- 6.0.39-1ubuntu0.1+esm2
- 6.0.39-1ubuntu0.1+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
tomcat6 Ubuntu:16.04:LTS
- Версии
- 6.0.41-4
- 6.0.45+dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 6.0.45+dfsg-1ubuntu0.1
Обновитесь до 6.0.45+dfsg-1ubuntu0.1
tomcat7 Ubuntu:16.04:LTS
- Версии
- 7.0.64-1
- 7.0.68-1
- 7.0.68-1ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.0.68-1ubuntu0.3
Обновитесь до 7.0.68-1ubuntu0.3
tomcat8 Ubuntu:16.04:LTS
- Версии
- 8.0.26-1
- 8.0.28-1
- 8.0.30-1
- 8.0.32-1
- 8.0.32-1ubuntu1
- 8.0.32-1ubuntu1.1
- 8.0.32-1ubuntu1.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 8.0.32-1ubuntu1.3
Обновитесь до 8.0.32-1ubuntu1.3
Первоисточники
- http://rhn.redhat.com/errata/RHSA-2017-0250.html
- https://www.exploit-db.com/exploits/41783/
- https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.39
- https://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.0.M13
- http://www.securityfocus.com/bid/94461
- http://www.debian.org/security/2016/dsa-3738
- https://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.73
- http://rhn.redhat.com/errata/RHSA-2017-0244.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2017-3236626.html
- https://access.redhat.com/errata/RHSA-2017:0935
- https://security.netapp.com/advisory/ntap-20180607-0001/
- http://rhn.redhat.com/errata/RHSA-2017-0457.html
- http://rhn.redhat.com/errata/RHSA-2017-0246.html
- http://www.securitytracker.com/id/1037332
- https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.8
- https://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.48
- https://access.redhat.com/errata/RHSA-2017:0455
- http://rhn.redhat.com/errata/RHSA-2017-0527.html
- http://rhn.redhat.com/errata/RHSA-2017-0245.html
- https://access.redhat.com/errata/RHSA-2017:0456
- http://rhn.redhat.com/errata/RHSA-2017-0247.html
- https://lists.apache.org/thread.html/343558d982879bf88ec20dbf707f8c11255f8e219e81d45c4f8d0551%40%3Cdev.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/b8a1bf18155b552dcf9a928ba808cbadad84c236d85eab3033662cfb%40%3Cdev.tomcat.apache.org%3E
- https://nvd.nist.gov/vuln/detail/CVE-2016-6816