CVE-2017-20165
CVE-2017-20165 · debug-js debug node.js useColors redos
CVSS 3.5 · Низкий · EPSS 2,1% · Есть исправление
Затронуты ли вы?
- debugНет опубликованного исправления
- node-debug Debian 12Обновитесь до 3.1.0-1
- node-debug Debian 13Обновитесь до 3.1.0-1
- node-debug Debian 14Обновитесь до 3.1.0-1
- и ещё 3
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="node-debug"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания debug и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The identifier of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability.
- Опубликовано
- Обновлено
Затронутые продукты и версии
debug
- Версии
- 3.0: Затронуто
Нет опубликованного исправления
node-debug Debian 12
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.1.0-1
Обновитесь до 3.1.0-1
node-debug Debian 13
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.1.0-1
Обновитесь до 3.1.0-1
node-debug Debian 14
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.1.0-1
Обновитесь до 3.1.0-1
debug npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.1.0
Обновитесь до 3.1.0
debug npm
- Затронутые диапазоны версий
- SEMVER: < 2.6.9
Обновитесь до 2.6.9
node-debug Ubuntu 16.04 LTS
- Версии
- 2.1.0+dfsg-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-debug Ubuntu 18.04 LTS
- Версии
- 2.5.1-2
- 3.1.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления