p PatchFirst

CVE-2017-3731

CVE-2017-3731 · Truncated packet could crash via OOB read

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

If an SSL/TLS server or client is running on a 32-bit host, and a specific cipher is being used, then a truncated packet can cause that server or client to perform an out-of-bounds read, usually resulting in a crash. For OpenSSL 1.1.0, the crash can be triggered when using CHACHA20/POLY1305; users should upgrade to 1.1.0d. For Openssl 1.0.2, the crash can be triggered when using RC4-MD5; users who have not disabled that algorithm should update to 1.0.2k.

CVSS 7.5 · Высокий · EPSS 57,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · network

Затронутые продукты и версии

  • openssl

    Версии
    • openssl-1.1.0: Затронуто
    • openssl-1.1.0a: Затронуто
    • openssl-1.1.0b: Затронуто
    • openssl-1.1.0c: Затронуто
    • openssl-1.0.2: Затронуто
    • openssl-1.0.2a: Затронуто
    • openssl-1.0.2b: Затронуто
    • openssl-1.0.2c: Затронуто
    • openssl-1.0.2d: Затронуто
    • openssl-1.0.2e: Затронуто
    • openssl-1.0.2f: Затронуто
    • openssl-1.0.2g: Затронуто
    • openssl-1.0.2h: Затронуто
    • openssl-1.0.2i: Затронуто
    • openssl-1.0.2j: Затронуто

    Нет опубликованного исправления

  • openssl Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.0d-1

    Обновитесь до 1.1.0d-1

  • openssl Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.0d-1

    Обновитесь до 1.1.0d-1

  • openssl Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.0d-1

    Обновитесь до 1.1.0d-1

  • openssl Ubuntu:14.04:LTS

    Версии
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    • 1.0.1f-1ubuntu2.19
    • 1.0.1f-1ubuntu2.20
    • 1.0.1f-1ubuntu2.21
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.22

    Обновитесь до 1.0.1f-1ubuntu2.22

  • openssl Ubuntu:16.04:LTS

    Версии
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.6

    Обновитесь до 1.0.2g-1ubuntu4.6

Первоисточники

Проверьте свой сервер →