p PatchFirst

CVE-2018-0739

CVE-2018-0739 · Constructed ASN.1 types with a recursive definition could exceed the stack

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.

Constructed ASN.1 types with a recursive definition (such as can be found in PKCS7) could eventually exceed the stack given malicious input with excessive recursion. This could result in a Denial Of Service attack. There are no such structures used within SSL/TLS that come from untrusted sources so this is considered safe. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g). Fixed in OpenSSL 1.0.2o (Affected 1.0.2b-1.0.2n).

CVSS 6.5 · Средний · EPSS 18,6% · Есть исправление

Опубликовано
Обновлено

Стек: system · network

Затронутые продукты и версии

  • openssl

    Версии
    • Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g): Затронуто
    • Fixed in OpenSSL 1.0.2o (Affected 1.0.2b-1.0.2n): Затронуто

    Нет опубликованного исправления

  • libtomcrypt Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.18.2-1

    Обновитесь до 1.18.2-1

  • libtomcrypt Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.18.2-1

    Обновитесь до 1.18.2-1

  • libtomcrypt Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.18.2-1

    Обновитесь до 1.18.2-1

  • openssl Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.0h-1

    Обновитесь до 1.1.0h-1

  • openssl Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.0h-1

    Обновитесь до 1.1.0h-1

  • openssl Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.0h-1

    Обновитесь до 1.1.0h-1

  • openssl Ubuntu:14.04:LTS

    Версии
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    • 1.0.1f-1ubuntu2.19
    • 1.0.1f-1ubuntu2.20
    • 1.0.1f-1ubuntu2.21
    • 1.0.1f-1ubuntu2.22
    • 1.0.1f-1ubuntu2.23
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.24

    Обновитесь до 1.0.1f-1ubuntu2.24

  • openssl Ubuntu:16.04:LTS

    Версии
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    • 1.0.2g-1ubuntu4.10
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.11

    Обновитесь до 1.0.2g-1ubuntu4.11

  • openssl Ubuntu:18.04:LTS

    Версии
    • 1.0.2g-1ubuntu13
    • 1.0.2g-1ubuntu14
    • 1.0.2n-1ubuntu1
    • 1.1.0g-2ubuntu1
    • 1.1.0g-2ubuntu2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.0g-2ubuntu3

    Обновитесь до 1.1.0g-2ubuntu3

  • openssl1.0 Ubuntu:18.04:LTS

    Версии
    • 1.0.2n-1ubuntu2
    • 1.0.2n-1ubuntu3
    • 1.0.2n-1ubuntu4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.0.2n-1ubuntu5

    Обновитесь до 1.0.2n-1ubuntu5

Первоисточники

Проверьте свой сервер →