p PatchFirst

CVE-2018-1000180

CVE-2018-1000180

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added certainty may have less M-R tests than expected. This appears to be fixed in versions BC 1.60 beta 4 and later, BC-FJA 1.0.2 and later.

CVSS 7.5 · Высокий · EPSS 3,4% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • bouncycastle Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.59-2

    Обновитесь до 1.59-2

  • bouncycastle Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.59-2

    Обновитесь до 1.59-2

  • bouncycastle Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.59-2

    Обновитесь до 1.59-2

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Версии
    • 1.57-1
    • 1.58-1
    • 1.59-1
    • 1.59-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →