p PatchFirst

CVE-2018-1000300

CVE-2018-1000300

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.

CVSS 9.8 · Критический · EPSS 4,7% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • curl Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.60.0-1

    Обновитесь до 7.60.0-1

  • curl Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.60.0-1

    Обновитесь до 7.60.0-1

  • curl Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.60.0-1

    Обновитесь до 7.60.0-1

  • curl Ubuntu:18.04:LTS

    Версии
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.58.0-2ubuntu3.1

    Обновитесь до 7.58.0-2ubuntu3.1

Первоисточники

Проверьте свой сервер →