p PatchFirst

CVE-2018-1000622

CVE-2018-1000622

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

CVSS 7.8 · Высокий · EPSS 1,8% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • rustc Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.27.1+dfsg1-1~exp1

    Обновитесь до 1.27.1+dfsg1-1~exp1

  • rustc Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.27.1+dfsg1-1~exp1

    Обновитесь до 1.27.1+dfsg1-1~exp1

  • rustc Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.27.1+dfsg1-1~exp1

    Обновитесь до 1.27.1+dfsg1-1~exp1

Первоисточники

Проверьте свой сервер →