p PatchFirst

CVE-2018-1000807

CVE-2018-1000807

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.

CVSS 8.1 · Высокий · EPSS 4,1% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • pyopenssl Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 17.5.0-1

    Обновитесь до 17.5.0-1

  • pyopenssl Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 17.5.0-1

    Обновитесь до 17.5.0-1

  • pyopenssl Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 17.5.0-1

    Обновитесь до 17.5.0-1

  • pyopenssl PyPI

    Версии
    • 0.10
    • 0.11
    • 0.12
    • 0.13
    • 0.13.1
    • 0.14
    • 0.15
    • 0.15.1
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 16.0.0
    • 16.1.0
    • 16.2.0
    • 17.0.0
    • 17.1.0
    • 17.2.0
    • 17.3.0
    • 17.4.0
    Затронутые диапазоны версий
    • ECOSYSTEM: < 17.5.0

    Обновитесь до 17.5.0

  • pyopenssl Ubuntu:16.04:LTS

    Версии
    • 0.15.1-2build1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.15.1-2ubuntu0.2

    Обновитесь до 0.15.1-2ubuntu0.2

Первоисточники

Проверьте свой сервер →