p PatchFirst

CVE-2018-1000810

CVE-2018-1000810

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

CVSS 9.8 · Критический · EPSS 3,0% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • rustc Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Обновитесь до 1.30.0+dfsg1-1

  • rustc Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Обновитесь до 1.30.0+dfsg1-1

  • rustc Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Обновитесь до 1.30.0+dfsg1-1

Первоисточники

Проверьте свой сервер →