p PatchFirst

CVE-2018-8007

CVE-2018-8007

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Apache CouchDB administrative users can configure the database server via HTTP(S). Due to insufficient validation of administrator-supplied configuration settings via the HTTP API, it is possible for a CouchDB administrator user to escalate their privileges to that of the operating system's user that CouchDB runs under, by bypassing the blacklist of configuration settings that are not allowed to be modified via the HTTP API. This privilege escalation effectively allows an existing CouchDB admin user to gain arbitrary remote code execution, bypassing already disclosed CVE-2017-12636. Mitigation: All users should upgrade to CouchDB releases 1.7.2 or 2.1.2.

CVSS 7.2 · Высокий · EPSS 12,2%

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache couchdb

    Версии
    • < 1.7.2: Затронуто
    • 2.0.0 to 2.1.1: Затронуто

    Нет опубликованного исправления

  • couchdb Ubuntu:16.04:LTS

    Версии
    • 1.6.0-0ubuntu7
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →