p PatchFirst

CVE-2019-1010266

CVE-2019-1010266

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.

CVSS 6.5 · Средний · EPSS 3,0% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • lodash

    Версии
    • <4.17.11 [fixed: 4.7.11]: Затронуто

    Нет опубликованного исправления

  • node-lodash Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.17.11+dfsg-1

    Обновитесь до 4.17.11+dfsg-1

  • node-lodash Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.17.11+dfsg-1

    Обновитесь до 4.17.11+dfsg-1

  • node-lodash Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.17.11+dfsg-1

    Обновитесь до 4.17.11+dfsg-1

  • lodash npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.7.0, < 4.17.11

    Обновитесь до 4.17.11

  • lodash-es npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.7.0, < 4.17.11

    Обновитесь до 4.17.11

  • lodash-amd npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.7.0, < 4.17.11

    Обновитесь до 4.17.11

  • lodash-rails RubyGems

    Версии
    • 4.11.2
    • 4.12.0
    • 4.13.1
    • 4.14.1
    • 4.15.0
    • 4.16.1
    • 4.16.3
    • 4.16.4
    • 4.16.6
    • 4.17.10
    • 4.17.2
    • 4.17.4
    • 4.17.5
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.7.0, < 4.17.11

    Обновитесь до 4.17.11

  • node-lodash Ubuntu:Pro:18.04:LTS

    Версии
    • 4.17.4+dfsg-1
    • 4.17.4+dfsg-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →