p PatchFirst

CVE-2019-10163

CVE-2019-10163

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A Vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.9, 4.0.8 allowing a remote, authorized master server to cause a high CPU load or even prevent any further updates to any slave zone by sending a large number of NOTIFY messages. Note that only servers configured as slaves are affected by this issue.

CVSS 3.5 · Низкий · EPSS 1,0% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • pdns

    Версии
    • fixed in 4.1.9: Затронуто
    • fixed in 4.0.8: Затронуто

    Нет опубликованного исправления

  • pdns Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.1.6-3

    Обновитесь до 4.1.6-3

  • pdns Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.1.6-3

    Обновитесь до 4.1.6-3

  • pdns Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.1.6-3

    Обновитесь до 4.1.6-3

  • pdns Ubuntu:Pro:16.04:LTS

    Версии
    • 3.4.5-1build2
    • 3.4.6-2
    • 3.4.6-3
    • 3.4.7-1
    • 3.4.7-2
    • 4.0.0~alpha1-1
    • 4.0.0~alpha2-2
    • 4.0.0~alpha2-3
    • 4.0.0~alpha2-3build1
    • 4.0.0~alpha2-3ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • pdns Ubuntu:Pro:18.04:LTS

    Версии
    • 4.0.4-2
    • 4.0.4-2build1
    • 4.0.5-1
    • 4.1.0-1
    • 4.1.0-2
    • 4.1.0-2build1
    • 4.1.1-1
    • 4.1.1-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →