CVE-2019-16778
CVE-2019-16778 · Heap buffer overflow in `UnsortedSegmentSum` in TensorFlow
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
In TensorFlow before 1.15, a heap buffer overflow in UnsortedSegmentSum can be produced when the Index template argument is int32. In this case data_size and num_segments fields are truncated from int64 to int32 and can produce negative numbers, resulting in accessing out of bounds heap memory. This is unlikely to be exploitable and was detected and fixed internally in TensorFlow 1.15 and 2.0.
CVSS 2.6 · Низкий · EPSS 0,8% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
tensorflow
- Версии
- ≥ < 1.15, < 1.15: Затронуто (custom)
Нет опубликованного исправления
tensorflow PyPI
- Версии
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.15.0
Обновитесь до 1.15.0
tensorflow-cpu PyPI
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.15.0
Обновитесь до 1.15.0
tensorflow-gpu PyPI
- Версии
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.15.0
Обновитесь до 1.15.0
tensorflow PyPI
- Версии
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.0rc0
- 1.1.0rc1
- 1.1.0rc2
- 1.10.0
- 1.10.0rc0
- 1.10.0rc1
- 1.10.1
- 1.11.0
- 1.11.0rc0
- 1.11.0rc1
- 1.11.0rc2
- 1.12.0
- 1.12.0rc0
- 1.12.0rc1
- 1.12.0rc2
- 1.12.2
- 1.12.3
- 1.13.0rc0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.1
- 1.13.2
- 1.14.0
- 1.14.0rc0
- 1.14.0rc1
- 1.15.0rc0
- 1.15.0rc1
- 1.15.0rc2
- 1.15.0rc3
- 1.2.0
- 1.2.0rc0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.1
- 1.3.0
- 1.3.0rc0
- 1.3.0rc1
- 1.3.0rc2
- 1.4.0
- 1.4.0rc0
- 1.4.0rc1
- 1.4.1
- 1.5.0
- 1.5.0rc0
- 1.5.0rc1
- 1.5.1
- 1.6.0
- 1.6.0rc0
- 1.6.0rc1
- 1.7.0
- 1.7.0rc0
- 1.7.0rc1
- 1.7.1
- 1.8.0
- 1.8.0rc0
- 1.8.0rc1
- 1.9.0
- 1.9.0rc0
- 1.9.0rc1
- 1.9.0rc2
- Затронутые диапазоны версий
- GIT: < db4f9717c41bccc3ce10099ab61996b246099892
- ECOSYSTEM: ≥ 1.0.0, < 1.15.0
Обновитесь до 1.15.0
tensorflow-cpu PyPI
- Затронутые диапазоны версий
- GIT: < db4f9717c41bccc3ce10099ab61996b246099892
- ECOSYSTEM: ≥ 1.0.0, < 1.15.0
Обновитесь до 1.15.0
tensorflow-gpu PyPI
- Версии
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Затронутые диапазоны версий
- GIT: < db4f9717c41bccc3ce10099ab61996b246099892
- ECOSYSTEM: ≥ 1.0.0, < 1.15.0
Обновитесь до 1.15.0
Первоисточники
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-844w-j86r-4x2j
- https://github.com/tensorflow/tensorflow/commit/db4f9717c41bccc3ce10099ab61996b246099892
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2019-002.md
- https://nvd.nist.gov/vuln/detail/CVE-2019-16778