CVE-2019-16780
CVE-2019-16780 · Stored cross-site scripting (XSS) in WordPress block editor
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.
CVSS 5.8 · Средний · EPSS 1,7% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
wordpress
- Версии
- ≥ < 5.3.1, < 5.3.1: Затронуто (custom)
Нет опубликованного исправления
wordpress Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.2+dfsg1-1
Обновитесь до 5.3.2+dfsg1-1
wordpress Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.2+dfsg1-1
Обновитесь до 5.3.2+dfsg1-1
wordpress Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.2+dfsg1-1
Обновитесь до 5.3.2+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Версии
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wordpress Ubuntu:18.04:LTS
- Версии
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://wpvulndb.com/vulnerabilities/9976
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-x3wp-h3qx-9w94
- https://wordpress.org/news/2019/12/wordpress-5-3-1-security-and-maintenance-release/
- https://github.com/WordPress/wordpress-develop/commit/505dd6a20b6fc3d06130018c1caeff764248c29e
- https://hackerone.com/reports/738644
- https://seclists.org/bugtraq/2020/Jan/8
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://nvd.nist.gov/vuln/detail/CVE-2019-16780