p PatchFirst

CVE-2019-16785

CVE-2019-16785 · HTTP Request Smuggling: LF vs CRLF handling in Waitress

CVSS 7.1 · Высокий · EPSS 2,5% · Есть исправление

Затронуты ли вы?

  • waitressНет опубликованного исправления
  • waitress Debian 12Обновитесь до 1.4.1-1
  • waitress Debian 13Обновитесь до 1.4.1-1
  • waitress Debian 14Обновитесь до 1.4.1-1
  • и ещё 3

Как узнать установленную версию:

dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="waitress"'

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания waitress и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Waitress through version 1.3.1 implemented a "MAY" part of the RFC7230 which states: "Although the line terminator for the start-line and header fields is the sequence CRLF, a recipient MAY recognize a single LF as a line terminator and ignore any preceding CR." Unfortunately if a front-end server does not parse header fields with an LF the same way as it does those with a CRLF it can lead to the front-end and the back-end server parsing the same HTTP message in two different ways. This can lead to a potential for HTTP request smuggling/splitting whereby Waitress may see two requests while the front-end server only sees a single HTTP message. This issue is fixed in Waitress 1.4.0.

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • waitress

    Версии
    • ≥ <= 1.3.1, ≤ 1.3.1: Затронуто (custom)

    Нет опубликованного исправления

  • waitress Debian 12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.1-1

    Обновитесь до 1.4.1-1

  • waitress Debian 13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.1-1

    Обновитесь до 1.4.1-1

  • waitress Debian 14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.1-1

    Обновитесь до 1.4.1-1

  • waitress PyPI

    Версии
    • 0.1
    • 0.2
    • 0.3
    • 0.4
    • 0.5
    • 0.6
    Все версии (37)
    • 0.6.1
    • 0.7
    • 0.8
    • 0.8.1
    • 0.8.10
    • 0.8.11b0
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.6
    • 0.8.7
    • 0.8.8
    • 0.8.9
    • 0.9.0
    • 0.9.0b0
    • 0.9.0b1
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 1.0a1
    • 1.0a2
    • 1.1.0
    • 1.2.0
    • 1.2.0b1
    • 1.2.0b2
    • 1.2.0b3
    • 1.2.1
    • 1.3.0
    • 1.3.0b0
    • 1.3.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.4.0

    Обновитесь до 1.4.0

  • waitress PyPI

    Версии
    • 0.1
    • 0.2
    • 0.3
    • 0.4
    • 0.5
    • 0.6
    Все версии (37)
    • 0.6.1
    • 0.7
    • 0.8
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.6
    • 0.8.7
    • 0.8.8
    • 0.8.9
    • 0.8.10
    • 0.8.11b0
    • 0.9.0b0
    • 0.9.0b1
    • 0.9.0
    • 1.0a1
    • 1.0a2
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 1.1.0
    • 1.2.0b1
    • 1.2.0b2
    • 1.2.0b3
    • 1.2.0
    • 1.2.1
    • 1.3.0b0
    • 1.3.0
    • 1.3.1
    Затронутые диапазоны версий
    • GIT: < 8eba394ad75deaf9e5cd15b78a3d16b12e6b0eba
    • ECOSYSTEM: < 1.4.0

    Обновитесь до 1.4.0

  • waitress Ubuntu 16.04 LTS

    Версии
    • 0.8.9-2ubuntu1
    • 0.8.10-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • waitress Ubuntu 18.04 LTS

    Версии
    • 1.0.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →