p PatchFirst

CVE-2019-3829

CVE-2019-3829

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.

CVSS 5.3 · Средний · EPSS 59,0% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • gnutls

    Версии
    • fixed in 3.6.7: Затронуто
    • affected from 3.5.8: Затронуто

    Нет опубликованного исправления

  • gnutls28 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.6.7-2

    Обновитесь до 3.6.7-2

  • gnutls28 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.6.7-2

    Обновитесь до 3.6.7-2

  • gnutls28 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.6.7-2

    Обновитесь до 3.6.7-2

  • gnutls28 Ubuntu:18.04:LTS

    Версии
    • 3.5.8-6ubuntu3
    • 3.5.17-1ubuntu1
    • 3.5.17-1ubuntu3
    • 3.5.18-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.5.18-1ubuntu1.1

    Обновитесь до 3.5.18-1ubuntu1.1

Первоисточники

Проверьте свой сервер →