p PatchFirst

CVE-2019-5421

CVE-2019-5421

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

CVSS 9.8 · Критический · EPSS 1,6% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • devise ruby gem

    Версии
    • 4.5.0 and earlier using the lockable module: Затронуто

    Нет опубликованного исправления

  • ruby-devise Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.5.0-3

    Обновитесь до 4.5.0-3

  • gitlab Ubuntu:16.04:LTS

    Версии
    • 8.4.3+dfsg-9
    • 8.4.3+dfsg-12
    • 8.5.8+dfsg-5
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ruby-devise Ubuntu:18.04:LTS

    Версии
    • 4.2.0-1
    • 4.3.0-1
    • 4.4.3-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ruby-devise Ubuntu:20.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.5.0-3

    Обновитесь до 4.5.0-3

Первоисточники

Проверьте свой сервер →