p PatchFirst

CVE-2020-11023

CVE-2020-11023 · Potential XSS vulnerability in jQuery

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CVSS 6.9 · Средний · EPSS 84,9% · В каталоге KEV · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: system · php · node

Затронутые продукты и версии

  • jquery

    Версии
    • >= 1.0.3, < 3.5.0: Затронуто

    Нет опубликованного исправления

  • node-jquery Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Обновитесь до 3.5.0+dfsg-2

  • node-jquery Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Обновитесь до 3.5.0+dfsg-2

  • node-jquery Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.5.0+dfsg-2

    Обновитесь до 3.5.0+dfsg-2

  • znc Debian:12

    Версии
    • 1.10.1-1
    • 1.10.2-1
    • 1.10.3-1
    • 1.8.2-3.1
    • 1.8.2-3.1+deb12u1
    • 1.8.2-4
    • 1.9.0-1
    • 1.9.0-2
    • 1.9.1-1
    • 1.9.1-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • znc Debian:13

    Версии
    • 1.10.1-1
    • 1.10.2-1
    • 1.10.3-1
    • 1.9.1-2
    • 1.9.1-2+deb13u1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • znc Debian:14

    Версии
    • 1.10.1-1
    • 1.10.2-1
    • 1.9.1-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.10.3-1

    Обновитесь до 1.10.3-1

  • jquery npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 1.0.3, < 3.5.0

    Обновитесь до 3.5.0

  • jquery-rails RubyGems

    Версии
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 1.0
    • 1.0.1
    • 1.0.10
    • 1.0.11
    • 1.0.12
    • 1.0.13
    • 1.0.14
    • 1.0.15
    • 1.0.16
    • 1.0.17
    • 1.0.18
    • 1.0.19
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.7
    • 1.0.8
    • 1.0.9
    • 1.0.rc
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.1.4
    • 3.1.5
    • 4.0.0
    • 4.0.0.beta1
    • 4.0.0.beta2
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    • 4.1.0
    • 4.1.1
    • 4.2.0
    • 4.2.1
    • 4.2.2
    • 4.3.0
    • 4.3.1
    • 4.3.2
    • 4.3.3
    • 4.3.4
    • 4.3.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.4.0

    Обновитесь до 4.4.0

  • jquery NuGet

    Версии
    • 1.10.0
    • 1.10.0.1
    • 1.10.1
    • 1.10.2
    • 1.11.0
    • 1.11.1
    • 1.11.2
    • 1.11.3
    • 1.12.0
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.7.0
    • 1.7.1
    • 1.7.1.1
    • 1.7.2
    • 1.8.0
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.9.0
    • 1.9.1
    • 2.0.0
    • 2.0.1
    • 2.0.1.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 3.0.0
    • 3.0.0.1
    • 3.1.0
    • 3.1.1
    • 3.2.1
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.0.3, < 3.5.0

    Обновитесь до 3.5.0

  • org.webjars.npm:jquery Maven

    Версии
    • 1.11.0
    • 1.11.1
    • 1.11.3
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 1.7.2
    • 1.7.3
    • 1.8.2
    • 1.8.3
    • 1.9.1
    • 2.1.0
    • 2.1.1
    • 2.1.1-rc1
    • 2.1.1-rc2
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 3.0.0
    • 3.0.0-alpha1
    • 3.0.0-beta1
    • 3.0.0-rc1
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.2.1
    • 3.3.0
    • 3.3.1
    • 3.4.0
    • 3.4.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.0.3, < 3.5.0

    Обновитесь до 3.5.0

  • components/jquery Packagist

    Версии
    • 1.10.0
    • 1.10.1
    • 1.10.2
    • 1.11.0
    • 1.11.1
    • 1.11.2
    • 1.11.3
    • 1.12.0
    • 1.12.1
    • 1.12.4
    • 1.8.3
    • 1.9.0
    • 1.9.1
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.3
    • 2.1.4
    • 2.2.0
    • 2.2.1
    • 2.2.4
    • 3.0.0
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.2.1
    • 3.3.1
    • 3.4.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.0.3, < 3.5.0

    Обновитесь до 3.5.0

  • drupal7 Ubuntu:Pro:14.04:LTS

    Версии
    • 7.23-1
    • 7.24-1
    • 7.24-2
    • 7.26-1
    • 7.26-1ubuntu0.1
    • 7.26-1ubuntu0.1+esm1
    • 7.26-1ubuntu0.1+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.26-1ubuntu0.1+esm3

    Обновитесь до 7.26-1ubuntu0.1+esm3

  • drupal7 Ubuntu:Pro:16.04:LTS

    Версии
    • 7.38-1
    • 7.41-1
    • 7.44-1ubuntu1~16.04.0
    • 7.44-1ubuntu1~16.04.0+esm1
    • 7.44-1ubuntu1~16.04.0+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.44-1ubuntu1~16.04.0+esm3

    Обновитесь до 7.44-1ubuntu1~16.04.0+esm3

  • jquery Ubuntu:Pro:18.04:LTS

    Версии
    • 3.1.1-2
    • 3.2.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.2.1-1ubuntu0.1~esm1

    Обновитесь до 3.2.1-1ubuntu0.1~esm1

  • jquery Ubuntu:20.04:LTS

    Версии
    • 3.3.1~dfsg-3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.3.1~dfsg-3ubuntu0.1

    Обновитесь до 3.3.1~dfsg-3ubuntu0.1

Первоисточники

Проверьте свой сервер →