p PatchFirst

CVE-2020-11030

CVE-2020-11030 · Cross-site scripting (XSS) in Search block in WordPress

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

CVSS 6.4 · Средний · EPSS 1,4% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • wordpress

    Версии
    • >= 5.4.0, < 5.4.1: Затронуто
    • >= 5.3.0, < 5.3.3: Затронуто
    • >= 5.2.0, < 5.2.6: Затронуто
    • >= 5.1.0, < 5.1.5: Затронуто
    • >= 5.0.0, < 5.0.9: Затронуто
    • >= 4.9.0, < 4.9.14: Затронуто
    • >= 4.8.0, < 4.8.13: Затронуто
    • >= 4.7.0, < 4.7.17: Затронуто
    • >= 4.6.0, < 4.6.18: Затронуто
    • >= 4.5.0, < 4.5.21: Затронуто
    • >= 4.4.0, < 4.4.22: Затронуто
    • >= 4.3.0, < 4.3.23: Затронуто
    • >= 4.2.0, < 4.2.27: Затронуто
    • >= 4.1.0, < 4.1.30: Затронуто
    • >= 4.0.0, < 4.0.30: Затронуто
    • >= 3.9.0, < 3.9.31: Затронуто
    • >= 3.8.0, < 3.8.33: Затронуто
    • >= 3.7.0, < 3.7.33: Затронуто

    Нет опубликованного исправления

  • wordpress Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.1+dfsg1-1

    Обновитесь до 5.4.1+dfsg1-1

  • wordpress Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.1+dfsg1-1

    Обновитесь до 5.4.1+dfsg1-1

  • wordpress Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.1+dfsg1-1

    Обновитесь до 5.4.1+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Версии
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:18.04:LTS

    Версии
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:20.04:LTS

    Версии
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:22.04:LTS

    Версии
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:24.04:LTS

    Версии
    • 6.2+dfsg1-1ubuntu1
    • 6.4.3+dfsg1-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:25.10

    Версии
    • 6.7.2+dfsg1-1.1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:26.10

    Версии
    • 6.7.2+dfsg1-1.1ubuntu2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:26.04:LTS

    Версии
    • 6.7.2+dfsg1-1.1ubuntu1
    • 6.7.2+dfsg1-1.1ubuntu2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →