CVE-2020-11041
CVE-2020-11041 · Improper Validation of Array Index in FreeRDP
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.
CVSS 2.2 · Низкий · EPSS 1,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
freerdp
- Версии
- <= 2.0.0: Затронуто
Нет опубликованного исправления
freerdp2 Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1+dfsg1-1
Обновитесь до 2.1.1+dfsg1-1
freerdp2 Ubuntu:18.04:LTS
- Версии
- 2.0.0~git20170725.1.1648deb+dfsg1-1
- 2.0.0~git20170725.1.1648deb+dfsg1-5
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
- 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
- 2.0.0~git20170725.1.1648deb+dfsg1-6
- 2.0.0~git20170725.1.1648deb+dfsg1-6build1
- 2.0.0~git20170725.1.1648deb+dfsg1-7
- 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.18.04.1
Обновитесь до 2.1.1+dfsg1-0ubuntu0.18.04.1
freerdp2 Ubuntu:20.04:LTS
- Версии
- 2.0.0~git20190204.1.2693389a+dfsg1-1
- 2.0.0~git20190204.1.2693389a+dfsg1-2
- 2.0.0~git20190204.1.2693389a+dfsg1-2build1
- 2.0.0~git20190204.1.2693389a+dfsg1-2build2
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1+dfsg1-0ubuntu0.20.04.1
Обновитесь до 2.1.1+dfsg1-0ubuntu0.20.04.1