p PatchFirst

CVE-2020-11985

CVE-2020-11985

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

IP address spoofing when proxying using mod_remoteip and mod_rewrite For configurations using proxying with mod_remoteip and certain mod_rewrite rules, an attacker could spoof their IP address for logging and PHP scripts. Note this issue was fixed in Apache HTTP Server 2.4.24 but was retrospectively allocated a low severity CVE in 2020.

CVSS 5.3 · Средний · EPSS 7,0% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache http server

    Версии
    • 2.4.1 to 2.4.23: Затронуто

    Нет опубликованного исправления

  • apache2 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.25-1

    Обновитесь до 2.4.25-1

  • apache2 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.25-1

    Обновитесь до 2.4.25-1

  • apache2 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.25-1

    Обновитесь до 2.4.25-1

  • apache2 Ubuntu:Pro:14.04:LTS

    Версии
    • 2.4.6-2ubuntu2
    • 2.4.6-2ubuntu3
    • 2.4.6-2ubuntu4
    • 2.4.7-1ubuntu1
    • 2.4.7-1ubuntu2
    • 2.4.7-1ubuntu3
    • 2.4.7-1ubuntu4
    • 2.4.7-1ubuntu4.1
    • 2.4.7-1ubuntu4.4
    • 2.4.7-1ubuntu4.5
    • 2.4.7-1ubuntu4.6
    • 2.4.7-1ubuntu4.7
    • 2.4.7-1ubuntu4.8
    • 2.4.7-1ubuntu4.9
    • 2.4.7-1ubuntu4.10
    • 2.4.7-1ubuntu4.11
    • 2.4.7-1ubuntu4.13
    • 2.4.7-1ubuntu4.15
    • 2.4.7-1ubuntu4.16
    • 2.4.7-1ubuntu4.17
    • 2.4.7-1ubuntu4.18
    • 2.4.7-1ubuntu4.19
    • 2.4.7-1ubuntu4.20
    • 2.4.7-1ubuntu4.21
    • 2.4.7-1ubuntu4.22
    • 2.4.7-1ubuntu4.22+esm1
    • 2.4.7-1ubuntu4.22+esm2
    • 2.4.7-1ubuntu4.22+esm3
    • 2.4.7-1ubuntu4.22+esm4
    • 2.4.7-1ubuntu4.22+esm5
    • 2.4.7-1ubuntu4.22+esm6
    • 2.4.7-1ubuntu4.22+esm8
    • 2.4.7-1ubuntu4.22+esm9
    • 2.4.7-1ubuntu4.22+esm10
    • 2.4.7-1ubuntu4.22+esm12
    • 2.4.7-1ubuntu4.22+esm13
    • 2.4.7-1ubuntu4.22+esm14
    • 2.4.7-1ubuntu4.22+esm15
    • 2.4.7-1ubuntu4.22+esm16
    • 2.4.7-1ubuntu4.22+esm17
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • apache2 Ubuntu:16.04:LTS

    Версии
    • 2.4.12-2ubuntu2
    • 2.4.17-1ubuntu1
    • 2.4.17-2ubuntu1
    • 2.4.17-3ubuntu1
    • 2.4.18-1ubuntu1
    • 2.4.18-2ubuntu1
    • 2.4.18-2ubuntu2
    • 2.4.18-2ubuntu3
    • 2.4.18-2ubuntu3.1
    • 2.4.18-2ubuntu3.2
    • 2.4.18-2ubuntu3.3
    • 2.4.18-2ubuntu3.4
    • 2.4.18-2ubuntu3.5
    • 2.4.18-2ubuntu3.7
    • 2.4.18-2ubuntu3.8
    • 2.4.18-2ubuntu3.9
    • 2.4.18-2ubuntu3.10
    • 2.4.18-2ubuntu3.12
    • 2.4.18-2ubuntu3.13
    • 2.4.18-2ubuntu3.14
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.18-2ubuntu3.15

    Обновитесь до 2.4.18-2ubuntu3.15

Первоисточники

Проверьте свой сервер →