p PatchFirst

CVE-2020-1752

CVE-2020-1752

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A use-after-free vulnerability introduced in glibc upstream version 2.14 was found in the way the tilde expansion was carried out. Directory paths containing an initial tilde followed by a valid username were affected by this issue. A local attacker could exploit this flaw by creating a specially crafted path that, when processed by the glob function, would potentially lead to arbitrary code execution. This was fixed in version 2.32.

CVSS 7.0 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • glibc

    Версии
    • Affected: versions 2.14 and later: Затронуто
    • Fixed: version 2.32: Затронуто

    Нет опубликованного исправления

  • glibc Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.30-3

    Обновитесь до 2.30-3

  • glibc Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.30-3

    Обновитесь до 2.30-3

  • glibc Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.30-3

    Обновитесь до 2.30-3

  • eglibc Ubuntu:Pro:14.04:LTS

    Версии
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    • 2.19-0ubuntu6.4
    • 2.19-0ubuntu6.5
    • 2.19-0ubuntu6.6
    • 2.19-0ubuntu6.7
    • 2.19-0ubuntu6.8
    • 2.19-0ubuntu6.9
    • 2.19-0ubuntu6.10
    • 2.19-0ubuntu6.11
    • 2.19-0ubuntu6.13
    • 2.19-0ubuntu6.14
    • 2.19-0ubuntu6.15
    • 2.19-0ubuntu6.15+esm1
    • 2.19-0ubuntu6.15+esm2
    • 2.19-0ubuntu6.15+esm3
    • 2.19-0ubuntu6.15+esm4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • glibc Ubuntu:16.04:LTS

    Версии
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    • 2.23-0ubuntu6
    • 2.23-0ubuntu7
    • 2.23-0ubuntu9
    • 2.23-0ubuntu10
    • 2.23-0ubuntu11
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.23-0ubuntu11.2

    Обновитесь до 2.23-0ubuntu11.2

  • glibc Ubuntu:18.04:LTS

    Версии
    • 2.26-0ubuntu2
    • 2.26-0ubuntu2.1
    • 2.27-0ubuntu2
    • 2.27-0ubuntu3
    • 2.27-3ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.27-3ubuntu1.2

    Обновитесь до 2.27-3ubuntu1.2

Первоисточники

Проверьте свой сервер →