p PatchFirst

CVE-2020-25699

CVE-2020-25699

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

CVSS 7.5 · Высокий · EPSS 1,6% · Есть исправление

Опубликовано
Обновлено

Стек: system · php

Затронутые продукты и версии

  • moodle

    Версии
    • Fixed in 3.9.3: Затронуто
    • Fixed in 3.8.6: Затронуто
    • Fixed in 3.7.9: Затронуто
    • Fixed in 3.5.15: Затронуто
    • Fixed in 3.10: Затронуто

    Нет опубликованного исправления

  • moodle/moodle Packagist

    Версии
    • v3.9.0
    • v3.9.1
    • v3.9.2
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.9.0, < 3.9.3

    Обновитесь до 3.9.3

  • moodle/moodle Packagist

    Версии
    • v3.8.0
    • v3.8.1
    • v3.8.2
    • v3.8.3
    • v3.8.4
    • v3.8.5
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.8.0, < 3.8.6

    Обновитесь до 3.8.6

  • moodle/moodle Packagist

    Версии
    • v3.7.0
    • v3.7.1
    • v3.7.2
    • v3.7.3
    • v3.7.4
    • v3.7.5
    • v3.7.6
    • v3.7.7
    • v3.7.8
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.7.0, < 3.7.9

    Обновитесь до 3.7.9

  • moodle/moodle Packagist

    Версии
    • v3.5.0
    • v3.5.0-beta
    • v3.5.0-rc1
    • v3.5.1
    • v3.5.10
    • v3.5.11
    • v3.5.12
    • v3.5.13
    • v3.5.14
    • v3.5.2
    • v3.5.3
    • v3.5.4
    • v3.5.5
    • v3.5.6
    • v3.5.7
    • v3.5.8
    • v3.5.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.5, < 3.5.15

    Обновитесь до 3.5.15

  • moodle Ubuntu:Pro:16.04:LTS

    Версии
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • moodle Ubuntu:Pro:18.04:LTS

    Версии
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →