p PatchFirst

CVE-2020-4031

CVE-2020-4031 · Use-After-Free in gdi_SelectObject in FreeRDP

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

In FreeRDP before version 2.1.2, there is a use-after-free in gdi_SelectObject. All FreeRDP clients using compatibility mode with /relax-order-checks are affected. This is fixed in version 2.1.2.

CVSS 3.5 · Низкий · EPSS 1,6% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • freerdp

    Версии
    • < 2.1.2: Затронуто

    Нет опубликованного исправления

  • freerdp2 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.1.2+dfsg1-1

    Обновитесь до 2.1.2+dfsg1-1

  • freerdp2 Ubuntu:18.04:LTS

    Версии
    • 2.0.0~git20170725.1.1648deb+dfsg1-1
    • 2.0.0~git20170725.1.1648deb+dfsg1-5
    • 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu1
    • 2.0.0~git20170725.1.1648deb+dfsg1-5ubuntu2
    • 2.0.0~git20170725.1.1648deb+dfsg1-6
    • 2.0.0~git20170725.1.1648deb+dfsg1-6build1
    • 2.0.0~git20170725.1.1648deb+dfsg1-7
    • 2.0.0~git20170725.1.1648deb+dfsg1-7ubuntu0.1
    • 2.1.1+dfsg1-0ubuntu0.18.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.2.0+dfsg1-0ubuntu0.18.04.1

    Обновитесь до 2.2.0+dfsg1-0ubuntu0.18.04.1

  • freerdp2 Ubuntu:20.04:LTS

    Версии
    • 2.0.0~git20190204.1.2693389a+dfsg1-1
    • 2.0.0~git20190204.1.2693389a+dfsg1-2
    • 2.0.0~git20190204.1.2693389a+dfsg1-2build1
    • 2.0.0~git20190204.1.2693389a+dfsg1-2build2
    • 2.1.1+dfsg1-0ubuntu0.20.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.2.0+dfsg1-0ubuntu0.20.04.1

    Обновитесь до 2.2.0+dfsg1-0ubuntu0.20.04.1

Первоисточники

Проверьте свой сервер →