p PatchFirst

CVE-2020-4047

CVE-2020-4047 · Authenticated XSS via media attachment page in WordPress

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

CVSS 6.8 · Средний · EPSS 3,3% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • wordpress-develop

    Версии
    • >= 5.4.0, < 5.4.2: Затронуто
    • >= 5.3.0, < 5.3.4: Затронуто
    • >= 5.2.0, < 5.2.7: Затронуто
    • >= 5.1.0, < 5.1.6: Затронуто
    • >= 5.0.0, < 5.0.10: Затронуто
    • >= 4.9.0, < 4.9.15: Затронуто
    • >= 4.8.0, < 4.8.14: Затронуто
    • >= 4.7.0, < 4.7.18: Затронуто
    • >= 4.6.0, < 4.6.19: Затронуто
    • >= 4.5.0, < 4.5.22: Затронуто
    • >= 4.4.0, < 4.4.23: Затронуто
    • >= 4.3.0, < 4.3.24: Затронуто
    • >= 4.2.0, < 4.2.28: Затронуто
    • >= 4.1.0, < 4.1.31: Затронуто
    • >= 4.0.0, < 4.0.31: Затронуто
    • >= 3.9.0, < 3.9.32: Затронуто
    • >= 3.8.0, < 3.8.34: Затронуто
    • >= 3.7.0, < 3.7.34: Затронуто

    Нет опубликованного исправления

  • wordpress Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Обновитесь до 5.4.2+dfsg1-1

  • wordpress Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Обновитесь до 5.4.2+dfsg1-1

  • wordpress Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.4.2+dfsg1-1

    Обновитесь до 5.4.2+dfsg1-1

  • wordpress Ubuntu:16.04:LTS

    Версии
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:18.04:LTS

    Версии
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:20.04:LTS

    Версии
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • wordpress Ubuntu:22.04:LTS

    Версии
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →