p PatchFirst

CVE-2020-5215

CVE-2020-5215 · Segmentation faultin TensorFlow when converting a Python string to tf.float16

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

In TensorFlow before 1.15.2 and 2.0.1, converting a string (from Python) to a tf.float16 value results in a segmentation fault in eager mode as the format checks for this use case are only in the graph mode. This issue can lead to denial of service in inference/training where a malicious attacker can send a data point which contains a string instead of a tf.float16 value. Similar effects can be obtained by manipulating saved models and checkpoints whereby replacing a scalar tf.float16 value with a scalar string will trigger this issue due to automatic conversions. This can be easily reproduced by tf.constant("hello", tf.float16), if eager execution is enabled. This issue is patched in TensorFlow 1.15.1 and 2.0.1 with this vulnerability patched. TensorFlow 2.1.0 was released after we fixed the issue, thus it is not affected. Users are encouraged to switch to TensorFlow 1.15.1, 2.0.1 or 2.1.0.

CVSS 5.0 · Средний · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • tensorflow

    Версии
    • < 1.15.2: Затронуто
    • = 2.0.0: Затронуто

    Нет опубликованного исправления

  • tensorflow PyPI

    Версии
    • 0.12.0
    • 0.12.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.12.0
    • 1.12.2
    • 1.12.3
    • 1.13.1
    • 1.13.2
    • 1.14.0
    • 1.15.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.9.0
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.15.2

    Обновитесь до 1.15.2

  • tensorflow PyPI

    Версии
    • 2.0.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.1

    Обновитесь до 2.0.1

  • tensorflow-cpu PyPI

    Версии
    • 1.15.0
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.15.2

    Обновитесь до 1.15.2

  • tensorflow-cpu PyPI

    Версии
    • 2.0.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.1

    Обновитесь до 2.0.1

  • tensorflow-gpu PyPI

    Версии
    • 0.12.0
    • 0.12.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.12.0
    • 1.12.2
    • 1.12.3
    • 1.13.1
    • 1.13.2
    • 1.14.0
    • 1.15.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.9.0
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.15.2

    Обновитесь до 1.15.2

  • tensorflow-gpu PyPI

    Версии
    • 2.0.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.1

    Обновитесь до 2.0.1

  • tensorflow PyPI

    Версии
    • 0.12.0
    • 0.12.0rc0
    • 0.12.0rc1
    • 0.12.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.1.0rc0
    • 1.1.0rc1
    • 1.1.0rc2
    • 1.10.0
    • 1.10.0rc0
    • 1.10.0rc1
    • 1.10.1
    • 1.11.0
    • 1.11.0rc0
    • 1.11.0rc1
    • 1.11.0rc2
    • 1.12.0
    • 1.12.0rc0
    • 1.12.0rc1
    • 1.12.0rc2
    • 1.12.2
    • 1.12.3
    • 1.13.0rc0
    • 1.13.0rc1
    • 1.13.0rc2
    • 1.13.1
    • 1.13.2
    • 1.14.0
    • 1.14.0rc0
    • 1.14.0rc1
    • 1.15.0
    • 1.15.0rc0
    • 1.15.0rc1
    • 1.15.0rc2
    • 1.15.0rc3
    • 1.2.0
    • 1.2.0rc0
    • 1.2.0rc1
    • 1.2.0rc2
    • 1.2.1
    • 1.3.0
    • 1.3.0rc0
    • 1.3.0rc1
    • 1.3.0rc2
    • 1.4.0
    • 1.4.0rc0
    • 1.4.0rc1
    • 1.4.1
    • 1.5.0
    • 1.5.0rc0
    • 1.5.0rc1
    • 1.5.1
    • 1.6.0
    • 1.6.0rc0
    • 1.6.0rc1
    • 1.7.0
    • 1.7.0rc0
    • 1.7.0rc1
    • 1.7.1
    • 1.8.0
    • 1.8.0rc0
    • 1.8.0rc1
    • 1.9.0
    • 1.9.0rc0
    • 1.9.0rc1
    • 1.9.0rc2
    • 2.0.0
    Затронутые диапазоны версий
    • GIT: < 5ac1b9e24ff6afc465756edf845d2e9660bd34bf
    • ECOSYSTEM: < 1.15.2 ∪ ≥ 2.0.0, < 2.0.1

    Обновитесь до 1.15.2; Обновитесь до 2.0.1

  • tensorflow-cpu PyPI

    Версии
    • 1.15.0
    Затронутые диапазоны версий
    • GIT: < 5ac1b9e24ff6afc465756edf845d2e9660bd34bf
    • ECOSYSTEM: < 1.15.2 ∪ ≥ 2.0.0, < 2.0.1

    Обновитесь до 1.15.2; Обновитесь до 2.0.1

  • tensorflow-gpu PyPI

    Версии
    • 0.12.0
    • 0.12.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.10.0
    • 1.10.1
    • 1.11.0
    • 1.12.0
    • 1.12.2
    • 1.12.3
    • 1.13.1
    • 1.13.2
    • 1.14.0
    • 1.15.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.9.0
    • 2.0.0
    Затронутые диапазоны версий
    • GIT: < 5ac1b9e24ff6afc465756edf845d2e9660bd34bf
    • ECOSYSTEM: < 1.15.2 ∪ ≥ 2.0.0, < 2.0.1

    Обновитесь до 1.15.2; Обновитесь до 2.0.1

Первоисточники

Проверьте свой сервер →