p PatchFirst

CVE-2020-5263

CVE-2020-5263 · Information disclosure through error object

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

CVSS 5.5 · Средний · EPSS 0,9% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • auth0.js

    Версии
    • >= 8.0.0, < 9.12.3: Затронуто

    Нет опубликованного исправления

  • auth0-js npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 9.13.2

    Обновитесь до 9.13.2

Первоисточники

Проверьте свой сервер →