p PatchFirst

CVE-2020-8277

CVE-2020-8277

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service in versions < 15.2.1, < 14.15.1, and < 12.19.1 by getting the application to resolve a DNS record with a larger number of responses. This is fixed in 15.2.1, 14.15.1, and 12.19.1.

CVSS 7.5 · Высокий · EPSS 54,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • node.js

    Версии
    • ≥ 4.0, < 4.*: Затронуто (semver)
    • ≥ 5.0, < 5.*: Затронуто (semver)
    • ≥ 6.0, < 6.*: Затронуто (semver)
    • ≥ 7.0, < 7.*: Затронуто (semver)
    • ≥ 8.0, < 8.*: Затронуто (semver)
    • ≥ 9.0, < 9.*: Затронуто (semver)
    • ≥ 11.0, < 11.*: Затронуто (semver)
    • ≥ 12.0, < 12.19.1: Затронуто (semver)
    • ≥ 13.0, < 13.*: Затронуто (semver)
    • ≥ 14.0, < 14.15.1: Затронуто (semver)
    • ≥ 15.0, < 15.2.1: Затронуто (semver)

    Обновитесь до 12.19.1; Обновитесь до 14.15.1; Обновитесь до 15.2.1

  • c-ares Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.17.1-1

    Обновитесь до 1.17.1-1

  • c-ares Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.17.1-1

    Обновитесь до 1.17.1-1

  • c-ares Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.17.1-1

    Обновитесь до 1.17.1-1

Первоисточники

Проверьте свой сервер →