CVE-2020-8835
CVE-2020-8835 · Linux kernel bpf verifier vulnerability
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
In the Linux kernel 5.5.0 and newer, the bpf verifier (kernel/bpf/verifier.c) did not properly restrict the register bounds for 32-bit operations, leading to out-of-bounds reads and writes in kernel memory. The vulnerability also affects the Linux 5.4 stable series, starting with v5.4.7, as the introducing commit was backported to that branch. This vulnerability was fixed in 5.6.1, 5.5.14, and 5.4.29. (issue is aka ZDI-CAN-10780)
CVSS 7.8 · Высокий · EPSS 6,0% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
linux kernel
- Версии
- ≥ 5.6-stable, < 5.6.1: Затронуто (custom)
- ≥ 5.5-stable, < 5.5.14: Затронуто (custom)
- ≥ 5.4.7, < 5.4-stable*: Затронуто; ≥ 5.4.29: Не затронуто (custom)
Обновитесь до 5.4.29; Обновитесь до 5.5.14; Обновитесь до 5.6.1
linux Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.5.13-2
Обновитесь до 5.5.13-2
linux Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.5.13-2
Обновитесь до 5.5.13-2
linux Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.5.13-2
Обновитесь до 5.5.13-2
linux-azure-5.3 Ubuntu:18.04:LTS
- Версии
- 5.3.0-1007.8~18.04.1
- 5.3.0-1008.9~18.04.1
- 5.3.0-1009.10~18.04.1
- 5.3.0-1010.11~18.04.1
- 5.3.0-1012.13~18.04.1
- 5.3.0-1013.14~18.04.1
- 5.3.0-1016.17~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.0-1018.19~18.04.1
Обновитесь до 5.3.0-1018.19~18.04.1
linux-gcp-5.3 Ubuntu:18.04:LTS
- Версии
- 5.3.0-1008.9~18.04.1
- 5.3.0-1009.10~18.04.1
- 5.3.0-1010.11~18.04.1
- 5.3.0-1012.13~18.04.1
- 5.3.0-1014.15~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.0-1016.17~18.04.1
Обновитесь до 5.3.0-1016.17~18.04.1
linux-gke-5.3 Ubuntu:18.04:LTS
- Версии
- 5.3.0-1011.12~18.04.1
- 5.3.0-1012.13~18.04.1
- 5.3.0-1014.15~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.0-1016.17~18.04.1
Обновитесь до 5.3.0-1016.17~18.04.1
linux-hwe Ubuntu:18.04:LTS
- Версии
- 4.18.0-13.14~18.04.1
- 4.18.0-14.15~18.04.1
- 4.18.0-15.16~18.04.1
- 4.18.0-16.17~18.04.1
- 4.18.0-17.18~18.04.1
- 4.18.0-18.19~18.04.1
- 4.18.0-20.21~18.04.1
- 4.18.0-21.22~18.04.1
- 4.18.0-22.23~18.04.1
- 4.18.0-24.25~18.04.1
- 4.18.0-25.26~18.04.1
- 5.0.0-23.24~18.04.1
- 5.0.0-25.26~18.04.1
- 5.0.0-27.28~18.04.1
- 5.0.0-29.31~18.04.1
- 5.0.0-31.33~18.04.1
- 5.0.0-32.34~18.04.2
- 5.0.0-35.38~18.04.1
- 5.0.0-36.39~18.04.1
- 5.0.0-37.40~18.04.1
- 5.3.0-26.28~18.04.1
- 5.3.0-28.30~18.04.1
- 5.3.0-40.32~18.04.1
- 5.3.0-42.34~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.0-45.37~18.04.1
Обновитесь до 5.3.0-45.37~18.04.1
linux-oracle-5.3 Ubuntu:18.04:LTS
- Версии
- 5.3.0-1011.12~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.0-1013.14~18.04.1
Обновитесь до 5.3.0-1013.14~18.04.1
linux-raspi2-5.3 Ubuntu:18.04:LTS
- Версии
- 5.3.0-1017.19~18.04.1
- 5.3.0-1018.20~18.04.1
- 5.3.0-1019.21~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.3.0-1021.23~18.04.1
Обновитесь до 5.3.0-1021.23~18.04.1
linux-azure-edge Ubuntu:18.04:LTS
- Версии
- 4.18.0-1006.6~18.04.1
- 4.18.0-1007.7~18.04.1
- 4.18.0-1008.8~18.04.1
- 5.0.0-1012.12~18.04.2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
linux-gcp-edge Ubuntu:18.04:LTS
- Версии
- 4.18.0-1004.5~18.04.1
- 4.18.0-1005.6~18.04.1
- 4.18.0-1006.7~18.04.1
- 4.18.0-1007.8~18.04.1
- 4.18.0-1008.9~18.04.1
- 4.18.0-1009.10~18.04.1
- 4.18.0-1011.12~18.04.1
- 4.18.0-1012.13~18.04.1
- 4.18.0-1013.14~18.04.1
- 4.18.0-1015.16~18.04.1
- 5.0.0-1011.11~18.04.1
- 5.0.0-1013.13~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
linux-hwe-edge Ubuntu:18.04:LTS
- Версии
- 5.0.0-15.16~18.04.1
- 5.0.0-16.17~18.04.1
- 5.0.0-17.18~18.04.1
- 5.0.0-19.20~18.04.1
- 5.0.0-20.21~18.04.1
- 5.3.0-19.20~18.04.2
- 5.3.0-22.24~18.04.1
- 5.3.0-23.25~18.04.1
- 5.3.0-23.25~18.04.2
- 5.3.0-24.26~18.04.2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
linux-raspi2 Ubuntu:20.04:LTS
- Версии
- 5.3.0-1007.8
- 5.3.0-1014.16
- 5.3.0-1015.17
- 5.3.0-1017.19
- 5.4.0-1004.4
- 5.4.0-1006.6
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://usn.ubuntu.com/4313-1/
- https://www.thezdi.com/blog/2020/3/19/pwn2own-2020-day-one-results
- https://lore.kernel.org/bpf/20200330160324.15259-1-daniel%40iogearbox.net/T/
- https://www.openwall.com/lists/oss-security/2020/03/30/3
- https://usn.ubuntu.com/usn/usn-4313-1
- https://git.kernel.org/pub/scm/linux/kernel/git/netdev/net-next.git/commit/?id=f2d67fec0b43edce8c416101cdc52e71145b5fef
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=f2d67fec0b43edce8c416101cdc52e71145b5fef
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/F7OONYGMSYBEFHLHZJK3GOI5Z553G4LD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YXBWSHZ6DJIZVXKXGZPK6QPFCY7VKZEG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TF4PQZBEPNXDSK5DOBMW54OCLP25FTCD/
- https://security.netapp.com/advisory/ntap-20200430-0004/
- http://www.openwall.com/lists/oss-security/2021/07/20/1
- https://nvd.nist.gov/vuln/detail/CVE-2020-8835