CVE-2020-8897
CVE-2020-8897 · Robustness weakness in AWS KMS and Encryption SDKs
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A weak robustness vulnerability exists in the AWS Encryption SDKs for Java, Python, C and Javalcript prior to versions 2.0.0. Due to the non-committing property of AES-GCM (and other AEAD ciphers such as AES-GCM-SIV or (X)ChaCha20Poly1305) used by the SDKs to encrypt messages, an attacker can craft a unique cyphertext which will decrypt to multiple different results, and becomes especially relevant in a multi-recipient setting. We recommend users update their SDK to 2.0.0 or later.
CVSS 4.8 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
aws sdk
- Версии
- ≥ stable, < 2.0.0: Затронуто (custom)
Обновитесь до 2.0.0
com.amazonaws:aws-encryption-sdk-java Maven
- Версии
- 0.0.1
- 1.3.0
- 1.3.1
- 1.3.1-STAGING
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.6.1
- 1.6.2
- 1.7.0
- 1.9.0
- 1.9.1
- 1.9.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.0
Обновитесь до 2.0.0
aws-encryption-sdk PyPI
- Версии
- 1.10.0
- 1.10.1
- 1.2.0
- 1.2.2
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.7.1
- 1.9.0
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.0
Обновитесь до 2.0.0
aws-encryption-sdk PyPI
- Версии
- 1.2.0
- 1.2.2
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.7.1
- 1.9.0
- 1.10.0
- 1.10.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.0.0
Обновитесь до 2.0.0