CVE-2021-23177
CVE-2021-23177
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
An improper link resolution flaw while extracting an archive can lead to changing the access control list (ACL) of the target of the link. An attacker may provide a malicious archive to a victim user, who would trigger this flaw when trying to extract the archive. A local attacker may use this flaw to change the ACL of a file on the system and gain more privileges.
CVSS 7.8 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
libarchive
- Версии
- Fixed in libarchive 3.5.2: Затронуто
Нет опубликованного исправления
libarchive Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.5.2-1
Обновитесь до 3.5.2-1
libarchive Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.5.2-1
Обновитесь до 3.5.2-1
libarchive Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.5.2-1
Обновитесь до 3.5.2-1
libarchive Ubuntu:Pro:14.04:LTS
- Версии
- 3.1.2-5ubuntu1
- 3.1.2-7ubuntu1
- 3.1.2-7ubuntu2
- 3.1.2-7ubuntu2.1
- 3.1.2-7ubuntu2.2
- 3.1.2-7ubuntu2.3
- 3.1.2-7ubuntu2.4
- 3.1.2-7ubuntu2.6
- 3.1.2-7ubuntu2.7
- 3.1.2-7ubuntu2.8
- 3.1.2-7ubuntu2.8+esm1
- 3.1.2-7ubuntu2.8+esm3
- 3.1.2-7ubuntu2.8+esm4
- 3.1.2-7ubuntu2.8+esm5
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
libarchive Ubuntu:Pro:16.04:LTS
- Версии
- 3.1.2-11build1
- 3.1.2-11ubuntu0.16.04.1
- 3.1.2-11ubuntu0.16.04.2
- 3.1.2-11ubuntu0.16.04.3
- 3.1.2-11ubuntu0.16.04.4
- 3.1.2-11ubuntu0.16.04.5
- 3.1.2-11ubuntu0.16.04.6
- 3.1.2-11ubuntu0.16.04.7
- 3.1.2-11ubuntu0.16.04.8
- 3.1.2-11ubuntu0.16.04.8+esm1
- 3.1.2-11ubuntu0.16.04.8+esm2
- 3.1.2-11ubuntu0.16.04.8+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
libarchive Ubuntu:Pro:18.04:LTS
- Версии
- 3.2.2-3.1
- 3.2.2-3.1ubuntu0.1
- 3.2.2-3.1ubuntu0.2
- 3.2.2-3.1ubuntu0.3
- 3.2.2-3.1ubuntu0.4
- 3.2.2-3.1ubuntu0.5
- 3.2.2-3.1ubuntu0.6
- 3.2.2-3.1ubuntu0.7
- 3.2.2-3.1ubuntu0.7+esm1
- 3.2.2-3.1ubuntu0.7+esm2
- 3.2.2-3.1ubuntu0.7+esm3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
libarchive Ubuntu:20.04:LTS
- Версии
- 3.4.0-1
- 3.4.0-1build1
- 3.4.0-1ubuntu2
- 3.4.0-2ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.4.0-2ubuntu1.1
Обновитесь до 3.4.0-2ubuntu1.1
Первоисточники
- https://github.com/libarchive/libarchive/issues/1565
- https://github.com/libarchive/libarchive/commit/fba4f123cc456d2b2538f811bb831483bf336bad
- https://bugzilla.redhat.com/show_bug.cgi?id=2024245
- https://access.redhat.com/security/cve/CVE-2021-23177
- https://lists.debian.org/debian-lts-announce/2022/11/msg00030.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-23177