CVE-2021-27292
CVE-2021-27292
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
CVSS 7.5 · Высокий · EPSS 3,4% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
n/a
- Версии
- n/a: Затронуто
Нет опубликованного исправления
node-ua-parser-js Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.7.24+ds-1
Обновитесь до 0.7.24+ds-1
node-ua-parser-js Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.7.24+ds-1
Обновитесь до 0.7.24+ds-1
node-ua-parser-js Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.7.24+ds-1
Обновитесь до 0.7.24+ds-1
ua-parser-js npm
- Затронутые диапазоны версий
- SEMVER: ≥ 0.7.14, < 0.7.24
Обновитесь до 0.7.24
node-ua-parser-js Ubuntu:18.04:LTS
- Версии
- 0.7.14-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ua-parser-js Ubuntu:20.04:LTS
- Версии
- 0.7.14-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-ua-parser-js Ubuntu:22.04:LTS
- Версии
- 0.7.24+ds-1
- 0.7.24+ds-2
- 0.7.31+ds+~0.7.36-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления