CVE-2021-28957
CVE-2021-28957
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
An XSS vulnerability was discovered in python-lxml's clean module versions before 4.6.3. When disabling the safe_attrs_only and forms arguments, the Cleaner class does not remove the formaction attribute allowing for JS to bypass the sanitizer. A remote attacker could exploit this flaw to run arbitrary JS code on users who interact with incorrectly sanitized HTML. This issue is patched in lxml 4.6.3.
CVSS 6.1 · Средний · EPSS 4,0% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
n/a
- Версии
- n/a: Затронуто
Нет опубликованного исправления
lxml Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.6.3-1
Обновитесь до 4.6.3-1
lxml Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.6.3-1
Обновитесь до 4.6.3-1
lxml Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.6.3-1
Обновитесь до 4.6.3-1
lxml PyPI
- Версии
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 2.0
- 2.0.10
- 2.0.11
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.2
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 3.0
- 3.0.2
- 3.1.0
- 3.1.1
- 3.1.2
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.5.0
- 3.6.0
- 3.6.1
- 3.6.2
- 3.6.3
- 3.6.4
- 3.7.0
- 3.7.1
- 3.7.2
- 3.7.3
- 3.8.0
- 4.0.0
- 4.1.0
- 4.1.1
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.3.0
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.5.0
- 4.5.1
- 4.5.2
- 4.6.0
- 4.6.1
- 4.6.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.6.3
Обновитесь до 4.6.3
lxml PyPI
- Версии
- 0.9
- 0.9.1
- 0.9.2
- 1.0.beta
- 1.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.4
- 1.1alpha
- 1.1beta
- 1.1
- 1.1.1
- 1.1.2
- 1.2
- 1.2.1
- 1.3beta
- 1.3
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 2.0alpha1
- 2.0alpha2
- 2.0alpha3
- 2.0alpha4
- 2.0alpha5
- 2.0alpha6
- 2.0beta1
- 2.0beta2
- 2.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.0.10
- 2.0.11
- 2.1alpha1
- 2.1beta1
- 2.1beta2
- 2.1beta3
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.2alpha1
- 2.2beta1
- 2.2beta2
- 2.2beta3
- 2.2beta4
- 2.2
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.3alpha1
- 2.3alpha2
- 2.3beta1
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 3.0
- 3.0.1
- 3.0.2
- 3.1beta1
- 3.1.0
- 3.1.1
- 3.1.2
- 3.2.0
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3.0beta1
- 3.3.0beta2
- 3.3.0beta3
- 3.3.0beta4
- 3.3.0beta5
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.5.0b1
- 3.5.0
- 3.6.0
- 3.6.1
- 3.6.2
- 3.6.3
- 3.6.4
- 3.7.0
- 3.7.1
- 3.7.2
- 3.7.3
- 3.8.0
- 4.0.0
- 4.1.0
- 4.1.1
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.3.0
- 4.3.1
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.5.0
- 4.5.1
- 4.5.2
- 4.6.0
- 4.6.1
- 4.6.2
- Затронутые диапазоны версий
- GIT: < a5f9cb52079dc57477c460dbe6ba0f775e14a999
- ECOSYSTEM: < 4.6.3
Обновитесь до 4.6.3
lxml Ubuntu:Pro:14.04:LTS
- Версии
- 3.2.0-1
- 3.3.0~beta2-1
- 3.3.0~beta4-1
- 3.3.1-1
- 3.3.2-1
- 3.3.2-1build1
- 3.3.3-1
- 3.3.3-1ubuntu0.1
- 3.3.3-1ubuntu0.2
- 3.3.3-1ubuntu0.2+esm1
- 3.3.3-1ubuntu0.2+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.3.3-1ubuntu0.2+esm3
Обновитесь до 3.3.3-1ubuntu0.2+esm3
lxml Ubuntu:16.04:LTS
- Версии
- 3.4.4-1
- 3.5.0-1
- 3.5.0-1build1
- 3.5.0-1ubuntu0.1
- 3.5.0-1ubuntu0.2
- 3.5.0-1ubuntu0.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.5.0-1ubuntu0.4
Обновитесь до 3.5.0-1ubuntu0.4
lxml Ubuntu:18.04:LTS
- Версии
- 4.0.0-1
- 4.1.0-1
- 4.2.0-1
- 4.2.1-1
- 4.2.1-1ubuntu0.1
- 4.2.1-1ubuntu0.2
- 4.2.1-1ubuntu0.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.2.1-1ubuntu0.4
Обновитесь до 4.2.1-1ubuntu0.4
lxml Ubuntu:20.04:LTS
- Версии
- 4.4.1-1
- 4.4.1-1build1
- 4.4.2-1
- 4.5.0-1
- 4.5.0-1ubuntu0.1
- 4.5.0-1ubuntu0.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.5.0-1ubuntu0.3
Обновитесь до 4.5.0-1ubuntu0.3
Первоисточники
- https://bugs.launchpad.net/lxml/+bug/1888153
- https://github.com/lxml/lxml/pull/316/commits/10ec1b4e9f93713513a3264ed6158af22492f270
- https://lists.debian.org/debian-lts-announce/2021/03/msg00031.html
- https://www.debian.org/security/2021/dsa-4880
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3C2R44VDUY7FJVMAVRZ2WY7XYL4SVN45/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XXN3QPWCTQVOGW4BMWV3AUUZZ4NRZNSQ/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://github.com/lxml/lxml/commit/a5f9cb52079dc57477c460dbe6ba0f775e14a999
- https://security.netapp.com/advisory/ntap-20210521-0004/
- https://security.gentoo.org/glsa/202208-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-28957