CVE-2021-29458
CVE-2021-29458 · Out-of-bounds read in Exiv2::Internal::CrwMap::encode
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.3 and earlier. The out-of-bounds read is triggered when Exiv2 is used to write metadata into a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service by crashing Exiv2, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when writing the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as insert. The bug is fixed in version v0.27.4.
CVSS 5.5 · Средний · EPSS 1,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
exiv2
- Версии
- < 0.27.4: Затронуто
Нет опубликованного исправления
exiv2 Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.27.5-1
Обновитесь до 0.27.5-1
exiv2 Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.27.5-1
Обновитесь до 0.27.5-1
exiv2 Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.27.5-1
Обновитесь до 0.27.5-1
exiv2 Ubuntu:Pro:16.04:LTS
- Версии
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm1
Обновитесь до 0.25-2.1ubuntu16.04.7+esm1
exiv2 Ubuntu:18.04:LTS
- Версии
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.7
Обновитесь до 0.25-3.1ubuntu0.18.04.7
exiv2 Ubuntu:20.04:LTS
- Версии
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- Затронутые диапазоны версий
- ECOSYSTEM: < 0.27.2-8ubuntu2.2
Обновитесь до 0.27.2-8ubuntu2.2
Первоисточники
- https://github.com/Exiv2/exiv2/issues/1530
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-57jj-75fm-9rq5
- https://github.com/Exiv2/exiv2/pull/1536
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2XQT5F5IINTDYDAFGVGQZ7PMMLG7I5ZZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P2A5GMJEXQ5Q76JK6F6VKK5JYCLVFGKN/
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-29458