CVE-2021-32628
CVE-2021-32628 · Vulnerability in handling large ziplists
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Redis is an open source, in-memory database that persists on disk. An integer overflow bug in the ziplist data structure used by all versions of Redis can be exploited to corrupt the heap and potentially result with remote code execution. The vulnerability involves modifying the default ziplist configuration parameters (hash-max-ziplist-entries, hash-max-ziplist-value, zset-max-ziplist-entries or zset-max-ziplist-value) to a very large value, and then constructing specially crafted commands to create very large ziplists. The problem is fixed in Redis versions 6.2.6, 6.0.16, 5.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from modifying the above configuration parameters. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.
CVSS 7.5 · Высокий · EPSS 13,5% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
redis
- Версии
- >= 6.2.0, < 6.2.6: Затронуто
- >= 6.0.0, < 6.0.16: Затронуто
- < 5.0.14: Затронуто
Нет опубликованного исправления
redis Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Ubuntu:Pro:14.04:LTS
- Версии
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2:2.8.4-2ubuntu0.2+esm2
Обновитесь до 2:2.8.4-2ubuntu0.2+esm2
redis Ubuntu:Pro:16.04:LTS
- Версии
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- Затронутые диапазоны версий
- ECOSYSTEM: < 2:3.0.6-1ubuntu0.4+esm1
Обновитесь до 2:3.0.6-1ubuntu0.4+esm1
redis Ubuntu:Pro:18.04:LTS
- Версии
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm3
Обновитесь до 5:4.0.9-1ubuntu0.2+esm3
redis Ubuntu:Pro:20.04:LTS
- Версии
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm1
Обновитесь до 5:5.0.7-2ubuntu0.1+esm1
Первоисточники
- https://github.com/redis/redis/security/advisories/GHSA-vw22-qm3h-49pr
- https://github.com/redis/redis/commit/f6a40570fa63d5afdd596c78083d754081d80ae3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VL5KXFN3ATM7IIM7Q4O4PWTSRGZ5744Z/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WR5WKJWXD4D6S3DJCZ56V74ESLTDQRAB/
- https://www.debian.org/security/2021/dsa-5001
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20211104-0003/
- https://security.gentoo.org/glsa/202209-17
- https://nvd.nist.gov/vuln/detail/CVE-2021-32628