p PatchFirst

CVE-2021-32672

CVE-2021-32672 · Vulnerability in Lua Debugger in Redis

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Redis is an open source, in-memory database that persists on disk. When using the Redis Lua Debugger, users can send malformed requests that cause the debugger’s protocol parser to read data beyond the actual buffer. This issue affects all versions of Redis with Lua debugging support (3.2 or newer). The problem is fixed in versions 6.2.6, 6.0.16 and 5.0.14.

CVSS 5.3 · Средний · EPSS 1,7% · Есть исправление

Опубликовано
Обновлено

Стек: system · database

Затронутые продукты и версии

  • redis

    Версии
    • >= 3.2.0, < 5.0.14: Затронуто
    • >= 6.0.0, < 6.0.16: Затронуто
    • >= 6.0.0, < 6.2.6: Затронуто

    Нет опубликованного исправления

  • redis Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5:6.0.16-1

    Обновитесь до 5:6.0.16-1

  • redis Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5:6.0.16-1

    Обновитесь до 5:6.0.16-1

  • redis Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 5:6.0.16-1

    Обновитесь до 5:6.0.16-1

  • redis Ubuntu:Pro:18.04:LTS

    Версии
    • 4:4.0.1-7
    • 4:4.0.2-6
    • 4:4.0.2-9
    • 5:4.0.5-1
    • 5:4.0.6-1
    • 5:4.0.6-2
    • 5:4.0.7-1
    • 5:4.0.8-1
    • 5:4.0.8-2
    • 5:4.0.9-1
    • 5:4.0.9-1ubuntu0.1
    • 5:4.0.9-1ubuntu0.2
    • 5:4.0.9-1ubuntu0.2+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm3

    Обновитесь до 5:4.0.9-1ubuntu0.2+esm3

  • redis Ubuntu:Pro:20.04:LTS

    Версии
    • 5:5.0.5-2build1
    • 5:5.0.6-1
    • 5:5.0.7-1
    • 5:5.0.7-2
    • 5:5.0.7-2ubuntu0.1~esm1
    • 5:5.0.7-2ubuntu0.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm1

    Обновитесь до 5:5.0.7-2ubuntu0.1+esm1

Первоисточники

Проверьте свой сервер →