CVE-2021-32675
CVE-2021-32675 · DoS vulnerability in Redis
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Redis is an open source, in-memory database that persists on disk. When parsing an incoming Redis Standard Protocol (RESP) request, Redis allocates memory according to user-specified values which determine the number of elements (in the multi-bulk header) and size of each element (in the bulk header). An attacker delivering specially crafted requests over multiple connections can cause the server to allocate significant amount of memory. Because the same parsing mechanism is used to handle authentication requests, this vulnerability can also be exploited by unauthenticated users. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14. An additional workaround to mitigate this problem without patching the redis-server executable is to block access to prevent unauthenticated users from connecting to Redis. This can be done in different ways: Using network access control tools like firewalls, iptables, security groups, etc. or Enabling TLS and requiring users to authenticate using client side certificates.
CVSS 7.5 · Высокий · EPSS 16,1% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
redis
- Версии
- < 5.0.14: Затронуто
- >= 6.0.0, < 6.0.16: Затронуто
- >= 6.2.0, < 6.2.6: Затронуто
Нет опубликованного исправления
redis Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Ubuntu:Pro:14.04:LTS
- Версии
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2:2.8.4-2ubuntu0.2+esm2
Обновитесь до 2:2.8.4-2ubuntu0.2+esm2
redis Ubuntu:Pro:16.04:LTS
- Версии
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- Затронутые диапазоны версий
- ECOSYSTEM: < 2:3.0.6-1ubuntu0.4+esm1
Обновитесь до 2:3.0.6-1ubuntu0.4+esm1
redis Ubuntu:Pro:18.04:LTS
- Версии
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm3
Обновитесь до 5:4.0.9-1ubuntu0.2+esm3
redis Ubuntu:Pro:20.04:LTS
- Версии
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm1
Обновитесь до 5:5.0.7-2ubuntu0.1+esm1
Первоисточники
- https://github.com/redis/redis/security/advisories/GHSA-f6pw-v9gw-v64p
- https://github.com/redis/redis/commit/5674b0057ff2903d43eaff802017eddf37c360f8
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VL5KXFN3ATM7IIM7Q4O4PWTSRGZ5744Z/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
- https://lists.apache.org/thread.html/ra603ff6e04549d7f290f61f9b11e2d2e4dba693b05ff053f4ec6bc47%40%3Cnotifications.geode.apache.org%3E
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WR5WKJWXD4D6S3DJCZ56V74ESLTDQRAB/
- https://www.debian.org/security/2021/dsa-5001
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20211104-0003/
- https://security.gentoo.org/glsa/202209-17
- https://nvd.nist.gov/vuln/detail/CVE-2021-32675