p PatchFirst

CVE-2021-32702

CVE-2021-32702 · Reflected XSS from the callback handler's error query parameter

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.

CVSS 8.0 · Высокий · EPSS 1,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • nextjs-auth0

    Версии
    • < 1.4.2: Затронуто

    Нет опубликованного исправления

  • @auth0/nextjs-auth0 npm

    Затронутые диапазоны версий
    • SEMVER: < 1.4.2

    Обновитесь до 1.4.2

Первоисточники

Проверьте свой сервер →