p PatchFirst

CVE-2021-32714

CVE-2021-32714 · Integer Overflow in Chunked Transfer-Encoding

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.

CVSS 5.9 · Средний · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • hyper

    Версии
    • < 0.14.10: Затронуто

    Нет опубликованного исправления

  • rust-hyper Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.14.19-1

    Обновитесь до 0.14.19-1

  • rust-hyper Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.14.19-1

    Обновитесь до 0.14.19-1

  • rust-hyper Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.14.19-1

    Обновитесь до 0.14.19-1

  • rust-hyper Ubuntu:20.04:LTS

    Версии
    • 0.12.35-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →