p PatchFirst

CVE-2021-32715

CVE-2021-32715 · Lenient Parsing of Content-Length Header When Prefixed with Plus Sign

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

hyper is an HTTP library for rust. hyper's HTTP/1 server code had a flaw that incorrectly parses and accepts requests with a `Content-Length` header with a prefixed plus sign, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that doesn't parse such `Content-Length` headers, but forwards them, can result in "request smuggling" or "desync attacks". The flaw exists in all prior versions of hyper prior to 0.14.10, if built with `rustc` v1.5.0 or newer. The vulnerability is patched in hyper version 0.14.10. Two workarounds exist: One may reject requests manually that contain a plus sign prefix in the `Content-Length` header or ensure any upstream proxy handles `Content-Length` headers with a plus sign prefix.

CVSS 3.1 · Низкий · EPSS 1,1% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • hyper

    Версии
    • < 0.14.10: Затронуто

    Нет опубликованного исправления

  • rust-hyper Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.14.19-1

    Обновитесь до 0.14.19-1

  • rust-hyper Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.14.19-1

    Обновитесь до 0.14.19-1

  • rust-hyper Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.14.19-1

    Обновитесь до 0.14.19-1

  • rust-hyper Ubuntu:20.04:LTS

    Версии
    • 0.12.35-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →